Home ยป What is EIGRP Protocol? How to use EIGRP?

What is EIGRP Protocol? How to use EIGRP?

EIGRP, which stands for Enhanced Interior Gateway Routing Protocol, is a dynamic routing protocol used in computer networks to help routers exchange routing information efficiently. It was developed by Cisco Systems and is primarily designed for use in IP networks, including both local area networks (LANs) and wide area networks (WANs).

EIGRP is an advanced distance-vector routing protocol that incorporates some characteristics of link-state protocols, making it a hybrid routing protocol. Some key features and characteristics of EIGRP include:

  1. Fast Convergence: EIGRP is designed to quickly adapt to changes in the network topology, ensuring that routing tables are updated swiftly in response to link failures or network modifications.
  2. Efficient Bandwidth Usage: EIGRP minimizes the amount of routing information exchanged between routers, which helps conserve bandwidth in the network.
  3. Load Balancing: EIGRP supports equal-cost load balancing, which means it can distribute traffic across multiple paths that have the same metric, improving network utilization.
  4. VLSM (Variable Length Subnet Mask) Support: EIGRP can work effectively with networks that use VLSM, allowing for more efficient utilization of IP address space.
  5. Loop-Free Routing: Like most distance-vector protocols, EIGRP ensures that routing loops do not occur by using various loop-prevention mechanisms.

EIGRP is typically used within Cisco-based networks, as it is a proprietary protocol. It is often preferred in medium to large-scale enterprise networks and can be employed in various scenarios, including:

  1. Campus Networks: EIGRP can be used to provide internal routing within large corporate campuses where multiple routers and subnets need to communicate efficiently.
  2. Corporate WANs: EIGRP is suitable for connecting remote offices and branches in a wide area network, facilitating communication between different locations.
  3. Internet Edge: EIGRP can be used in the edge routers that connect an organization’s internal network to the Internet, providing efficient routing of traffic to and from the public Internet.
  4. Data Center Networks: EIGRP can be used to support the routing needs within data center environments, where quick convergence and efficient bandwidth usage are essential.

It’s important to note that while EIGRP is a powerful and feature-rich routing protocol, it is proprietary to Cisco, and its use may be limited to Cisco devices. For networks with multi-vendor equipment, the use of standard protocols like OSPF (Open Shortest Path First) or BGP (Border Gateway Protocol) may be more appropriate.

In this example, we will have 5 different networks. As network device, there will be 3 routers, 2 L3 switches. At the end of this training we will be able to ping from Laptop 6 to Laptop 7 using routers which are connected through EIGRP protocol.

At first phase we will define IP addresses to all necessary ports as mentioned in our topology. Then we will start configuring EIGRP routes.

LOW LEVEL DIAGRAM (LLD)

ON ROUTER 1 >

interface GigabitEthernet0/0
 ip address 10.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 50.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 20.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!

ON ROUTER 2 >

interface GigabitEthernet0/0
 ip address 30.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 ip address 20.0.0.2 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!

ON ROUTER 3 >

interface GigabitEthernet0/0
 ip address 10.0.0.2 255.0.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 30.0.0.2 255.0.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 40.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!

We defined all the IP addresses to necessary ports. For the switches all you have to do is to define ‘ip default-gateway XX.xx.XX.xx’ as the nearest gateway. Now we will define the EIGRP routes.

ON ROUTER 1 – EIGRP CONFIGURATION >

router eigrp 10
 network 50.0.0.0
 network 10.0.0.0
 network 20.0.0.0

ON ROUTER 2 – EIGRP CONFIGURATION >

router eigrp 10
 network 20.0.0.0
 network 30.0.0.0

ON ROUTER 3 – EIGRP CONFIGURATION >

router eigrp 10
 network 40.0.0.0
 network 10.0.0.0
 network 30.0.0.0

So as of now, all networks are defined and lets check the EIGRP summary on the router 1. For this we will use below command :

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   20.0.0.2        Gig0/2         10   00:19:17  40     1000  0   18
1   10.0.0.2        Gig0/0         11   00:19:17  40     1000  0   13

R1#

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/8 is directly connected, GigabitEthernet0/0
L       10.0.0.1/32 is directly connected, GigabitEthernet0/0
     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       20.0.0.0/8 is directly connected, GigabitEthernet0/2
L       20.0.0.1/32 is directly connected, GigabitEthernet0/2
D    30.0.0.0/8 [90/3072] via 20.0.0.2, 00:04:30, GigabitEthernet0/2
                [90/3072] via 10.0.0.2, 00:04:30, GigabitEthernet0/0
D    40.0.0.0/8 [90/5376] via 10.0.0.2, 00:04:30, GigabitEthernet0/0
     50.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       50.0.0.0/8 is directly connected, GigabitEthernet0/1
L       50.0.0.1/32 is directly connected, GigabitEthernet0/1

To practice more you may find Cisco Packet Tracer simulator file below.

Please feel free to contact me if you have further questions with Interior Gateway Protocols.

Happy networking ๐Ÿ™‚

Related Posts

error: Content is protected !!