Home ยป What is “traceroute” command? How does it work on Windows OS?
tracert command on Windows OS

What is “traceroute” command? How does it work on Windows OS?

The traceroute command is a network troubleshooting tool used to trace the path of data packets from one host to another. It works by sending out a series of TCP/IP packets with increasing Time-To-Live (TTL) values. As each packet passes through switches and routers, the TTL value is decremented until it reaches 0, at which point the router sends back an ICMP “Time Exceeded” message. By analyzing this information, a user can get detailed information about the route taken by the data packets and identify potential problems in their network. This command is available on all Windows OS versions for both local and remote network troubleshooting purposes.

“Traceroute” example on a healthy connection;

Go to Command Line Interface (CMD) and then type “tracert” command + space + “destination address”. Now you will wait for Windows to list all the hops that packages goes through. If there is a problem in a hop (switch, router etc) you will recognize this failure.

We need to configure all clients with a static IP address. Sector – A is on 192.168.10.0/24 network. And Sector – B is on 192.168.20.0/24 network. We will also divert traffic between the sites using 2 routers with 10.10.1.1/8 and 10.10.1.2/8 interfaces.

At the first step, configure all clients with designated IP addresses as below.

Then type the necessary commands on the routers to make a static routing connection between the sites.

ROUTER -1 SECTOR – A

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface g0/0/1
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/1, changed state to up

Router(config-if)#exit
Router(config)#int g0/0/0
Router(config-if)#ip address 10.10.1.1 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up

Router(config-if)#exit
Router(config)#do wr
Building configuration...
[OK]
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up

Router(config)#ip route 192.168.20.0 255.255.255.0 10.10.1.2
Router(config)#do wr
Building configuration...
[OK]
Router(config)#

ROUTER – 2 SECTOR -B

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface g0/0
Router(config-if)#ip address 10.10.1.2 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#do wr
Building configuration...
[OK]
Router(config)#ip route 192.168.10.0 255.255.255.0 10.10.1.1
Router(config)#do wr
Building configuration...
[OK]
Router(config)#

After these configurations, you will be able to ping clients from Sector A which are on Sector B. Let’s use “tracert” command to see which hops our packages goes through.

As we can see from the above terminal, our data packages goes to our first Gateway as 192.168.10.1 and then goes to next destination as we created a static routing between networks. Then finds its final destination.

After inital setup, you should wait for a short while to make sure that all network devices has updated its ARP table. Otherwise you cannot communicate.

Now we will turn off the Router-2 which is our gateway to SECTOR-B on purpose. This way we will be able to understand where the “tracert” command shows us problem.

Turn off the second ROUTER as shown below.

As you can see our bridge to SECTOR B is down. So we will try to reach and examine the route with “tracert” command to see where exactly the problem is. Go to terminal CMD, type “tracert 192.168.20.10” to see where our packages dropped.

Tracert is tool is very useful for basic network troubleshooting. We detected that our packages drops at Router-2 as we turned it off.

Please feel free to contact me regarding your system and network related questions.

Have a great day ๐Ÿ™‚

Related Posts

error: Content is protected !!