Home ยป What is Voice VLAN? How to use IP Phones on our network?

What is Voice VLAN? How to use IP Phones on our network?

VOIP Communication Diagram

Voice VLAN is used to provide voice traffic with a dedicated VLAN. Voice traffic is isolated from other network traffic and so it doesn’t slow down the network.

In order to make a work voice vlan and computer together, you should turn on the voice vlan in your cisco phone.

This is done by providing a separate subnet for the voice traffic and assigning it to the phone.

Voice VLANs are an important component of VoIP networks because they provide an additional layer of security.

IMPORTANT : Please keep in mind that there are 3 different methods for VOIP communication.

1 – Direct cabling from access switch and enabling as switchport access and switchport voice vlan ( This requires a VOIP phone which supports CDP (Cisco Discovery Protocol). We preferred this method on this example.

2 – Direct cabling from access switch with 2 different cables defined for 2 different VLANs as access vlan for computer and voice vlan for VOIP. But the disadvantage of this method is to lose 2 ports on the switch.

3 – Using Native VLAN method to carry VOIP data. Trunk port will carry both tagged datas and native vlan datas. So we can use both access vlan and native vlan as voice vlan.

Okay, let’s start with creating VLANs,

SWITCH – 1

Switch1>en
Switch1#config terminal
Switch1(config)#vlan 10
Switch1(config-vlan)#vlan 20
Switch1(config-vlan)#vlan 30   ## We will use VLAN 30 as our VOICE VLAN
Switch1(config-vlan)#vlan 40
Switch1(config-vlan)#exit

Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 10.10.1.1 255.0.0.0
Switch1(config-if)#ip helper-address 40.10.1.10
Switch1(config-if)#no shutdown
Switch1(config-if)#exit
Switch1(config)#do wr

Switch1(config)#interface vlan 20
Switch1(config-if)#ip address 20.10.1.1 255.0.0.0
Switch1(config-if)#ip helper-address 40.10.1.10
Switch1(config-if)#no shutdown
Switch1(config-if)#exit
Switch1(config)#do wr

Switch1(config)#interface vlan 30
Switch1(config-if)#ip address 30.10.1.1 255.0.0.0
Switch1(config-if)#ip helper-address 40.10.1.10
Switch1(config-if)#no shutdown
Switch1(config-if)#exit
Switch1(config)#do wr

Switch1(config)#interface vlan 40
Switch1(config-if)#ip address 10.10.1.1 255.0.0.0
Switch1(config-if)#ip helper-address 40.10.1.10
Switch1(config-if)#no shutdown
Switch1(config-if)#exit
Switch1(config)#do wr


Switch1(config)#int g1/0/2
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 10
Switch1(config-if)#exit

Switch1(config)#int g1/0/24   ## This port connected to DHCP Server port
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 40
Switch1(config-if)#exit

Switch1(config)#int g1/0/3
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 20
Switch1(config-if)#switchport voice vlan 30
Switch1(config-if)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch1(config-if)#exit
Switch1(config)#interface g1/0/1
Switch1(config-if)#switchport trunk encapsulation dot1q
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#do wr

Switch(config)#ip routing  ## DO NOT FORGET TO ENABLE "ip routing"command
Switch(config)#do wr

IMPORTANT : On Cisco VOIP phones and on many other branded phones, there is an internal switch for forwarding VLAN data for access purposes. Internal switch recognize and differantiates VOICE VLAN data and ACCESS VLAN data. So we can use only 1 cable from the access switches. On the same cable we will be able to carry voice vlan data and access data for the computer.

Okay now it is turn for 2nd switch configuration,

SWITCH – 2

Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#vlan 30
Switch(config-vlan)#vlan 40
Switch(config-vlan)#exit
Switch(config)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]

Switch(config)#int g1/0/1

Switch(config-if)#sw trunk encapsulation dot1q
Switch(config-if)#sw mode trunk
Switch(config-if)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch(config-if)#exit
Switch(config)#


Switch(config)#interface g1/0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#switchport voice vlan 30
Switch(config-if)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch(config-if)#exit

Switch(config)#int g1/0/3
Switch(config-if)#sw mode acc
Switch(config-if)#sw acc vlan 20
Switch(config-if)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch(config-if)#


Switch(config)#interface g1/0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport voice vlan 30
Switch(config-if)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch(config-if)#exit

Switch(config-if)#exit
Switch(config)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch(config)#ip routing
Switch(config)#do wr
Building configuration...
Compressed configuration from 7383 bytes to 3601 bytes[OK]
[OK]
Switch(config)#
error: Content is protected !!