Home ยป What is dynamic routing in Cisco? How to create dynamic routing on router devices?

What is dynamic routing in Cisco? How to create dynamic routing on router devices?

Dynamic routing is a feature of Cisco routers that allows them to adjust routing paths based on changes in the network environment. It allows for more efficient use of router resources and helps ensure that traffic is routed optimally. With dynamic routing, router devices can automatically select the best route for data packets to reach their destination.

In this article, we will look at how to create dynamic routing on router devices and discuss the benefits of using dynamic routing in Cisco networks. We will also explore some of the common use cases for dynamic routing as well as some tips for setting up and managing a dynamic routing system.

In this topology, we will enable dynamic routing between 3 networks on 2 routers.

ROUTER - 1

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip	
Router(config-router)#network 10.0.0.0
Router(config-router)#network 20.0.0.0
Router(config-router)#do wr
Building configuration...
[OK]
Router(config-router)#exit
Router(config)#int g0/0
Router(config-if)#no sh

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int g0/1
Router(config-if)#no sh

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Router(config-if)#do wr
Building configuration...
[OK]
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int g0/1
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#do wr
Building configuration...
[OK]
Router(config-if)#exit
Router(config)#int g0/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#do wr
Building configuration...
[OK]
Router(config-if)#exit
Router(config)#
ROUTER - 2

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 20.0.0.0
Router(config-router)#network 30.0.0.0
Router(config-router)#do wr
Building configuration...
[OK]
Router(config-router)#exit
Router(config)#int g0/0
Router(config-if)#no sh

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int g0/1
Router(config-if)#no sh

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Router(config-if)#do wr
Building configuration...
[OK]
Router(config-if)#
Router(config-if)#exit
Router(config)#int g0/0
Router(config-if)#ip address 20.0.0.2 255.0.0.0
Router(config-if)#do wr
Building configuration...
[OK]
Router(config-if)#exit
Router(config)#int g0/1
Router(config-if)#ip address 30.0.0.1
% Incomplete command.
Router(config-if)#ip address 30.0.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#do wr
Building configuration...
[OK]
Router(config-if)#

Related Posts

error: Content is protected !!